Installation 0.8.0

From DVD-Slideshow
Jump to: navigation, search

Download dvd-slideshow from Sourceforge

Requires:

First, you'll need all of the required packages in order to create
and burn a dvd:

ImageMagick > 5.5.4
Sox
dvdauthor > 0.6.11
lame [required for mp3 decoding]
oggdec [required for ogg decoding]
mkisofs
dvdrtools [to actually burn dvds]
ffmpeg > 0.4.8 [ for ac3 audio ]

In order to install the dvd-slideshow package, you can copy the executables
into a bin directory in your path.  Man pages are provided in man/ and there
are also some documents in the doc/ directory.

OR

You can execute (as root):
sh install.sh

This will simply do the following:


## install some files and such:
# copy documentation:
cp man/dvd-slideshow.1 /usr/local/man/man1/.
cp man/dvd-menu.1 /usr/local/man/man1/.
cp man/dir2slideshow.1 /usr/local/man/man1/.
cp man/gallery1-to-slideshow.1 /usr/local/man/man1/.
cp man/jigl2slideshow.1 /usr/local/man/man1/.

# copy executables:
cp dvd-slideshow /usr/bin/.
cp dvd-menu /usr/bin/.
cp gallery1-to-slideshow /usr/bin/.
cp jigl2slideshow /usr/bin/.
cp dir2slideshow /usr/bin/.

remove old versions:
if [ -r "/usr/bin/gallery2slideshow" ] ; then
        echo "Removing old gallery2slideshow and installing gallery1-to-slideshow instead"
        echo "See changelog for details."
        rm "/usr/bin/gallery2slideshow"
        rm "/usr/local/man/man1/gallery2slideshow.1"
fi

Distributions

Note that repositories often have quite old versions of dvd-slideshow!

  • Gentoo Linux

dvd-slideshow is in the stable branch of portage, just type "emerge -av1 dvd-slideshow"

  • Suse Linux

You can install dvd-slideshow with yast.

  • Ubuntu Linux (Dapper Drake)
    • You can find dvd-slideshow in the multiverse repository.
    • Install it with "apt-get install dvd-slideshow"
    • It is easiest to use System -> Administration -> Synaptic Package Manager and search for each dependent package that dvd-slideshow uses to install them properly
  • Debian Linux
    • You can find dvd-slideshow in the debian-multimedia repository which can be accessed by adding the following line to your /etc/apt/sources.list
    • Then either "Reload" if you're using synaptic, or type "apt-get update" at the command line
    • Then search for dvd-slideshow and install!
  • NOTE: The current version of ffmpeg (version 3:20070309-0.0) in Lenny (testing) has a known bug with dvd-slideshow
    • If you have trouble encoding audio with a Debian based distro try this
      • remove ffmpeg, which will also uninstall dvd-slideshow
      • install ffmpeg from Etch(stable) which is (as of 2006-June-26) version 0.cvs20060823-8
      • re-install dvd-slideshow
      • give it a try!